Rpc connection problem

If I go into sytem → network → https portal and expose to json rpc of geth or rinkeby I get a public url, but when I try to use that public url it doesn’t seem to work, can somebody tell me if I need to elaborate in some way that link? it is something like rinkeby.xxx.dyndns.dappnode.io or geth.xxx.dyndns.dappnode.io

Hey!

I just notice that the issue might be because you are not using the prefix: https//. If you copy the link address you will notice that it comes with https://

Also, how do you verify it does not work? It may take some time to your dappnode to do the configuration necessary.

I suggest you to check it using one of the following methods:

  1. Open a terminal and execute the following command to check your RPC is working:
curl --location --request POST 'https://rinkeby.xxxx.dyndns.dappnode.io' --header 'Content-Type: application/json' --data-raw '{
        "jsonrpc":"2.0",
        "method":"web3_clientVersion",
        "params":[],
        "id":1
}'
  1. To avoid doing tecnical stuff, simply go to this website and set your RPC endpoint to do a test using any of the method available. An example screenshot:

@pablo
Thank you for your response, yes I have tried both with https and http as prefix, but it still doesn’t work, I have a web3 project that I use to check if the rpc is good, and everytime I use the one given me by appnode it fails, so the rpc doesn’t work