Prysm pyrmont issue

Hi

I am getting the below errors on Pyrsm Pyrmont after importing wallet. It is saying not connected and “Invalid genesisTime undefined” on the Prysm Pyrmont app in Dashboard. I tried last night and left it overnight but did not work so deleted the prism pyrmont and Goerli Geth apps and tried importing the wallet again.

My NUC is pretty loud at the moment and was loud when I left it overnight too.

Also wondering if I should be using Remote, Light Client or Full Node. I have selected Full Node however it says Status: Not available (using remote) - is syncing.

Any assistance is appreciated. Wondering if it is best to just start over or just wait longer?

Log in beacon chain
time=“2021-06-07 03:55:30” level=error msg=“Could not connect to powchain endpoint” error=“could not dial eth1 nodes: eth1 node has not finished syncing yet” prefix=powchain

Log in validator

time=“2021-06-07 00:47:45” level=warning msg=“You are using the --web option but have not yet signed via a browser. If your web host and port are exposed to the Internet, someone else can attempt to sign up for you! You can visit http://0.0.0.0:80 to view the Prysm web interface” prefix=rpc
time=“2021-06-07 00:48:09” level=info msg=“Successfully created wallet with ability to import keystores” --wallet-dir="/root/.eth2validators" prefix=accounts

Update… I restarted my NUC. Seems to be connecting ok now.

However still have the error on the Prysm Pyrmont app on the dashboard.

I have the same exact error on the dappnode dashboard. I cannot access the Pyrmont dashboard at all; it sends me to a import wallet screen as if the validator doesn’t exist.

When I check Pyrmont.beaconcha.in, I’m validating, though.

I’ve tried restarting the Pyrmont package with no luck. I noticed the beacon chain package is gone. I haven’t paid much attention to my node in awhile so it appears they combined the beacon chain and Pyrmont packages into one? I had problems with getting it in sync in the past and I just restarted it. That didn’t work this time. No idea what to do next.

Right know there 3 visual bugs:

  • Dappnode stopped or unreachable this happens after change the graffiti, it’s a dappnode bug, and it’s fixed for the next release.
  • Invalid genesisTIme undefined: it’s a visual bug, because prysm changed the api, and the function to get the genesis and calculate the sync have changed, until the new release we can’t update this function. It’s fixed for the next release.
  • On the Prysm UI, there is a bug (prysm bug, not dappnode this time), i would check in https://beaconcha.in/ if your validator is working. They have said they will fix this bug for the next version.
1 Like