Can't connect to DAppNode using subdomain.dyndns.appnode.io address

Hello there!

I’m trying my first installation of DAppNode on my own hardware (Intel Avaton CPU, 8GB RAM, 256GB SSD Drives). I’ve got Debian-10 installed with command-line mode (no GUI).

I was able to install both the prerequisites and the DAppNode package. Installation is completed and I am greeted with Barcode and Web link to log in.

From another Linux machine, I’m able to ping this machine’s local IP Address (192.168.1.9). I’m also able to use the following command successfully:

telnet 192.168.1.9 8092
ping subdomain.dyndns.dappnode.io

nc -z -v -u 192.168.1.9 1194
nc -z -v -u subdomain.dyndns.dappnode.io 1194

However, I was not able to complete this command successfully:
telnet subdomain.dyndns.dappnode.io 8092

Where subdomain is the name of my subdomain.

I’ve opened up TCP 8092 → 192.168.1.9 and UDP 1194 → 192.168.1.9 on my router. After that didn’t work, I also tried using DMZ → 192.168.1.9.

Please help when you can. Thanks.

UPDATE (6/10/2021):

I was able to get DAppNode working on another machine by using Port Forwarding instead of Bridged Networking.

Full disclosure: I’ve installed DAppNode as KVM VM using Libvirt. By default, my machine uses the ens3 interface that’s usually reserved for my internal network. I can create bridged network on ens6 interface but that didn’t seem to work. Once i forwarded port on ens3 interface, it started working!

Is there a way to define DAppNode to use different interface (such as ens6) as default network specifically for DAppNode?

UPDATE (6/14/2021):

I was able to make some progress, but still not resolved.

In the file located here: /etc/network/interfaces

I put in the network interfaces (ens3 and ens6) in the auto section. This will bring up all interfaces (similar to if -a command) during startup.

# The loopback network interface
auto lo ens3 ens6
iface lo inet loopback

So the bridged network interface (ens6) is now populated with IP Address during startup. I still cannot connect through bridged network (ens6). I can only connect through (ens3) with port forwarding.

Hey!

Sorry for the time response delay

To be honest networking is not my expertise, but I assume that all the stuff you are talking about is related to the dappnode wifi docker container (I have assumed you have tecnical knowledge): GitHub - dappnode/DNP_WIFI: DAppNode package responsible for providing wifi access to the internal network.

This suggestion could be a great feature to be implemented, would you mind to open an issue so we dappnode team can discuss if implement it and how? https://github.com/dappnode/DNP_WIFI/issues/new?assignees=&labels=&template=feature_request.md&title=

1 Like

Hi Pablo:

I put this out in the forums because someone running DAppNode as Virtual Machine with more than one network interface may know how to do this.

I’ll create an open issue on this using the link.

Thanks.