What am I doing right (wrong)? Question on ports checklist item

Hi all, I have been working on setting up a dappnode extreme for an Eth2 node. It seems like everything is working great on the testnet. pyrmont.beaconcha.in and dashboards are showing attestations just fine. I have worked through the checklists here and here:

However, with 1 exception and that was opening ports. I did not open ports on my router yet (att), but I also do not have UPnP (I don’t think…).

on my.dappnode under support->auto diagnose:

X Ports have to be opened and there is no UPnP device available

  • If you are capable of opening ports manually, please ignore this error
  • Your router may have UPnP but it is not turned on yet. Please research if your specific router has UPnP and turn it on

However, everything is working… but why?

I have an att router with apple airport extreme on double NAT. Here is the port scan:

private dappnode IP
Port Scanning host: 10.0.1.xx

 Open TCP Port: 	4001   		newoak
 Open TCP Port: 	8092		- openvpn
 Open TCP Port: 	8333		- bitcoin
 Open TCP Port: 	49153		- goerli geth
 Open TCP Port: 	49158		- prysm
 Open TCP Port: 	49159		- geth

Port Scan has completed…

public dappnode ip
Port Scanning host: x.x.x.x

 Open TCP Port: 	21     		ftp
 Open TCP Port: 	53     		domain -dns resolution
 Open TCP Port: 	554    		rtsp -media streaming
 Open TCP Port: 	7070   		arcp -media streaming
 Open TCP Port: 	10999		?

Port Scan has completed…

If I use netcat (mac terminal), then I can confirm port 21/FTP is working on my public IP as above, however, trying something like port 8092 from the public IP (or others there) is refused. Yet, everything seems to work…

Any ideas? Thanks!

@weiuohg
Hi there, welcome to DAppNode community!

Everything is working fine, let me give you a better explanation about which ports are importante in DAppNode and why.

There are three main important ways of connecting to your dappnode:

  1. Wifi hostpot:
  2. VPN: allows you to connect from anywhere in a secure way to your DappNode
  3. ssh: only recommended for users with tecnical knowledge

For method 2, is needed to have ports 8092 and 1194 to connect to your DAppNode via VPN.

Furhtermore, there are other ports (such as 49153 used by geth) used for P2P networking. This is an added value but not a mandatory requirement.

More information here

Conclusion:

  • If you want to connect through VPN to your DAppNode then you will have to enable UpNp.
  • Enable UpNp is not an error but a feature that allows you to connect through VPN and improve the P2P networking of your apps.

Hi Pablo,

Thanks for getting back. I have the VPN working, however, just on my LAN. My main concern was why is everything working (testnet eth2 validator) when I haven’t opened ports per the checklists #4… just to confirm, these aren’t necessary?

Thanks, wei

image

Hi @weiuohg

I’m not a networking expert but as far as I know, most of the ports needed in blockchain apps for syncing nodes (such as bitcoin, prysm…) are used to speed up the process of syncing.

So in most of the cases, it is not a requirement to have theses ports opened whereas it is recommended for a better experience.

1 Like

OK! Thanks again! Cheers

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.